Layer 3 Switch (Multilayer) İle VLAN Routing




Bu yazımızda Layer 3 Switch üzerinden VLAN’ler nasıl yönlendirilir bunu göreceğiz. Yukarıdaki topolojiye göre yapılandırmamızı gerçekleştireceğiz.

Öncelikle PC1 den PC4’e ping atarak arada bir iletişim olup olmadığını test edelim.

Gördüğünüz gibi bütün paketler kayboldu, zaten hali hazırda hiç bir yapılandırma yoktu, yapılandırma bitince iletişim sağlayabildiğimizi göreceksiniz.





Öncelikle tüm switchlerde VLAN’leri oluşturalım.

SW1#conf t

Enter configuration commands, one per line. End with CNTL/Z.

SW1(config)#vlan 10

SW1(config-vlan)#vlan 20

SW1(config-vlan)#

 

SW2#conf t

Enter configuration commands, one per line. End with CNTL/Z.

SW2(config)#vlan 10

SW2(config-vlan)#vlan 20

SW2(config-vlan)#

 

Layer3_SW#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Layer3_SW(config)#vlan 10

Layer3_SW(config-vlan)#vlan 20

Layer3_SW(config-vlan)#

 

SW1 ve SW2 deki ilgili portları VLAN’lere atayalım.

SW1(config)#int fa0/1

SW1(config-if)#switchport mode access

SW1(config-if)#switchport access vlan 10

SW1(config-if)#exi

SW1(config)#int fa0/2

SW1(config-if)#switchport mode access

SW1(config-if)#switchport access vlan 20

 

SW2(config)#int fa0/1

SW2(config-if)#switchport mode access

SW2(config-if)#switchport access vlan 10

SW2(config-if)#exi

SW2(config)#int fa0/2

SW2(config-if)#switchport mode access

SW2(config-if)#switchport access vlan 20





Her iki switchte de oluşturduğumuz vlanleri ve port atamasını show vlan brief komutu ile görebiliriz.

 

Şimdi Switchler arasındaki portları Trunk yapalım.

 

SW1(config)#interface gigabitEthernet 0/1

SW1(config-if)#switchport mode trunk

 

SW2(config)#interface gigabitEthernet 0/2

SW2(config-if)#switchport mode trunk

 

Layer3_SW(config)#interface range gigabitEthernet 0/1-2

Layer3_SW(config-if-range)#switchport trunk encapsulation dot1q

Layer3_SW(config-if-range)#switchport mode trunk

 

Layer 3 Switchte show interfaces trunk komutu ile Gi0/1 ve 0/2 portlarının Trunk olduğunu görebiliriz.

Şimdi sıra geldi Layer 3 Switchte Vlan 10 ve Vlan 20 için SVI oluşturmaya. Bu Switch Virtual Interface’ler bu vlanlar için gateway olarak yapılandırılmış olacak.

Layer3_SW(config)#interface vlan 10

Layer3_SW(config-if)#ip address 10.1.10.1 255.255.255.0

Layer3_SW(config-if)#exi

Layer3_SW(config)#interface vlan 20

Layer3_SW(config-if)#ip add 10.1.20.1 255.255.255.0

Layer3_SW(config-if)#end

Layer 3 Switchte show ip interface brief komutu ile bu gatewayleri görebiliriz.

Son olarak Layer 3 Switchte ip routing komutu ile ip yönlendirmeyi etkinleştirelim.

Layer3_SW(config)#ip routing

Şimdi show ip route komutu ile yönlendirme tablosunu görebiliriz.





Yönlendirme tablosunda iki vlane ait rotaları da gördüğümüze göre tekrar PC1’den PC4’e ping atmayı deneyelim.

Başarılı olduğuna göre vlanlar arası yönlendirme çalışıyor demektir.




İlk yorum yapan olun

Bir yanıt bırakın

E-posta hesabınız yayımlanmayacak.


*