HSRP Protokolü Nedir?




Yerel ağımızda hostlar arasında yedek yollar ve anahtarlar arasında yedek bağlantılar ile tam bir artıklık oluşturduğumuzda ve STP ile döngüleri önlediğimizde her şey bitmiş değildir. Aşağıdaki şekilde gördüğünüz gibi tek bir yönlendirici ile İnternet’e çıkan ağlarda, yani tek bir varsayılan ağ geçidinin olduğu durumda, varsayılan ağ geçidi olan yönlendirici arızalandığında veya anahtar ile yönlendirici arasındaki veya yönlendirici ile İnternet arasındaki bağlantı arızalandığında yerel ağdan İnternet’e çıkış kesilir. Bir yönlendiricinin, yedek varsayılan ağ geçidi olarak konumlandırıldığı ve  asıl varsayılan ağ geçidinin veya yolunun arızalandığı durumda devreye girdiği yapılarla varsayılan ağ geçidi artıklığı sağlanmış olur.

Varsayılan ağ geçidi artıklığı ile sanal bir yönlendirici oluşturulur ve bu sanal yönlendiricinin IP adresi varsayılan ağ geçidi olarak hostlarda yapılandırılır. Sanal yönlendirici ile birlikte sanal bir MAC adresi de oluşturulur ve hostlar varsayılan ağ geçidi MAC adresi olarak bunu kullanır. Bir ARP isteğinde , ARP cevabı olarak sanal yönlendiricinin MAC adresi döner. Mevcut varsayılan ağ geçidi ve yedek varsayılan ağ geçidi de bu sanal IP ve MAC adresini paylaşmış olur. Normal durumda sanal yönlendiricinin IP adresine ve MAC adresine gönderilen çerçeveler aktif varsayılan ağ geçidi tarafından işlenmektedir.  İşte iki veya daha fazla yönlendiriciyi gruplandırıp tek bir sanal yönlendirici oluşturmak için bir protokol kullanılır. Bu protokole FHRP(First Host Redundancy Protocol) İlk Sıçrama Yedeklilik Protokolü denir. Bu protokolle hangi yönlendiricinin aktif olarak trafiği ileteceği, hangi yönlendiricinin yedek (standby) olarak bekleyeceği ve ne zaman devreye gireceği belirlenir. Aşağıdaki şekilde aktif ve yedek yönlendirici ile sağlanmış varsayılan ağ geçidi artıklığı ve çalışması görülmektedir.

FHRP protokolleri olarak Cisco cihazlara özgü HSRP(Hot Standby Router Protocol-İletmeye Hazır Yönlendirici Protokolü) ve GLBP (Gateway Load Balancing Protocol-Varsayılan Ağ Geçidi Yük Dengeleme Protokolü) ile açık standart (RFC 5798) VRRP (Virtual Router Redundancy Protocol-Sanal Yönlendirici Yedeklilik Protokolü) karşımıza çıkmaktadır.

HSRP PROTOKOLÜ VE YAPILANDIRMASI

HSRP, Cisco’ya özel bir protokoldür. HSRP, bir grup yönlendirici tanımlar. Bunlardan biri aktif yani iletim (active) diğer bekleme (standby) durumundadır. Sanal IP ve MAC adresi iki yönlendirici arasında paylaşılır. HSRP yapılandırmasını doğrulamak için show standby  komutu kullanılır.

Bir aktif yönlendirici şu özelliklere sahiptir;

  • Varsayılan ağ geçidi MAC adresi ARP isteklerine sanal MAC adresi ile cevap verir.
  • Sanal yönlendirici için paketleri ileten aktif yönlendirici olarak çalışır.
  • Standby yönlendiriciye Hello mesajları gönderir. Yani görev başında olduğunu bildirir.
  • Sanal yönlendiricinin IP adresini bilir.

 

Bir standby yönlendirici şu özelliklere sahiptir;

  • Hello mesajları gönderir.
  • Periyodik hello mesajlarını dinler.
  • Aktif yönlendiriciden hello mesajı alamazsa görevi devir alır ve paketleri ileten aktif yönlendirici olarak çalışmaya başlar.

 

HSRP’nin 2 versiyonu vardır. Aşağıdaki tabloda HSRP versiyonları ve özellikleri gösterilmiştir.

 

HSRPv1 HSRPv2
Grup Numarası 0-255 0-4095
Sanal MAC Adresi 0000.0c07.acXX(XX = grup numarası) 0000.0c9f.fxxx (XXX = grup

numarası)

Hello mesajlarının gönderildiği multicast adres 224.0.0.2 224.0.0.102

Aşağıdaki topolojiye göre R1 ve R3 yönlendiricilerinde HSRP yapılandırması gerçekleştirelim.

 

Öncelikle her bir yönlendiricide yerel ağ tarafına bakan Gi0/0 arayüzlerini yapılandıralım. Böylelikle her bir yerel ağ için gateway yapılandırmış olacağız.

 

R1(config)#interface gigabitEthernet 0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no sh

 

R2(config)#interface gigabitEthernet 0/0

R2(config-if)#ip address 172.16.10.254 255.255.0.0

R2(config-if)#no sh

 

R3(config)#interface gigabitEthernet 0/0

R3(config-if)#ip address 192.168.1.2 255.255.255.0

R3(config-if)#no sh

 

Ardından yönlendiriciler arasındaki seri (serial) bağlantıları yapılandıralım.

 

R1(config)#interface serial 0/0/0

R1(config-if)#ip address 1.1.1.1 255.255.255.0

R1(config-if)#no sh

R2(config)#interface serial 0/0/0

R2(config-if)#ip address 1.1.1.2 255.255.255.0

R2(config-if)#no sh

R2(config-if)#exit

R2(config)#interface serial 0/0/1

R2(config-if)#ip address 2.2.2.1 255.255.255.0

R2(config-if)#no sh

 

R3(config)#interface serial 0/0/1

R3(config-if)#ip address 2.2.2.2 255.255.255.0

R3(config-if)#no sh

 

Şimdi de daha önce gördüğümüz RIP yapılandırmasını uygulayarak yönlendiriciler arasında routing yapalım.

 

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#network 1.1.1.0

R1(config-router)#network 192.168.1.0

 

R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#network 1.1.1.0

R2(config-router)#network 2.2.2.0

R2(config-router)#network 172.16.0.0

 

R3(config)#router rip

R3(config-router)#version 2

R3(config-router)#network 2.2.2.0

R3(config-router)#network 192.168.1.0

 

Şimdi PC1 için varsayılan ağ geçidi olarak 192.168.1.1, PC2 için varsayılan ağ geçidi olarak 192.168.1.2  yapılandıralım ve her iki PC’den sunucuya ping atalım bakalım routing çalışıyor mu?

 

Her iki PC’den de başarılı bir şekilde sunucuyu pinglemiş olmamız lazım. Şimdi de her iki PC’den sunucuya giden yolu takip edelim Bunun için tracert komutunu kullanıyoruz.

 

PC1’den tracert

 

C:\>tracert 172.16.10.100

 

Tracing route to 172.16.10.100 over a maximum of 30 hops:

 

1   0 ms      0 ms      0 ms      192.168.1.1

2   0 ms      1 ms      1 ms      2.2.2.1

3   11 ms     13 ms     13 ms     172.16.10.100

 

Trace complete.

 

 

PC2’den tracert

 

C:\>tracert 172.16.10.100

 

Tracing route to 172.16.10.100 over a maximum of 30 hops:

 

1   0 ms      1 ms      0 ms      192.168.1.2

2   1 ms      1 ms      1 ms      2.2.2.1

3   11 ms     17 ms     11 ms     172.16.10.100

 

Trace complete.

 

Dikkat ederseniz PC1 gateway olarak 192.168.1.1’den , PC2 gateway olarak 192.168.1.2’den çıkış yaptı. Şimdi HSRP yapılandırmasını gerçekleştirelim.

Öncelikle R1 de yapılandırmayı gerçekleştiriyoruz.

 

R1(config)#interface gigabitEthernet 0/0

R1(config-if)#standby 10 ip 192.168.1.3

R1(config-if)#standby 10 priority 150

R1(config-if)#standby 10 preempt

 

Yukarıdaki komutlarda standby 10 ip 192.168.1.3 ile Sanal IP adresini 192.168.1.3 ve grup numarasını 10  olarak belirledik. Bunu yazınca zaten ilk yapılandırılan yönlendirici olduğu için R1 aktif yönlendirici olur ve aşağıdaki mesaj konsolda görüntülenir.

 

%HSRP-6-STATECHANGE: GigabitEthernet0/0 Grp 10 state Speak -> Standby

%HSRP-6-STATECHANGE: GigabitEthernet0/0 Grp 10 stastandby 10

 

Sonrasında standby 10 priority 150 komutu ile R1’ öncelik tanıdık. Varsayılan priority değeri 100’dür. 0-255 arası değiştirilebilir. Öncelik değeri yüksek olan aktif yönlendirici  olur. Son olarak standby 10 preempt komutu ile R1’in aktifliğini kalıcı hale getirdik. Bunun anlamı şudur. R1 devreden çıkıp R3 devreye girdiğinde R1 standy, R3 aktif yönlendirici olur. R1 tekrar düzeldiğinde aktif yönlendirici görevini devir alır R3 standby durumuna geçer. Bu komut kullanılmadığı zaman R1 arızası giderilse bile standby kalmaya devam ederdi.

 

Şimdi R3’ü yapılandıralım.

 

R3(config)#interface gigabitEthernet 0/0

R3(config-if)#standby 10 ip 192.168.1.3

 

Artık PC1 ve PC2’de gateway olarak 192.168.1.3 girebilirsiniz. Her iki yönlendiricide show standby komutu ile HSRP yapılandırmasını doğrulayalım.

 

 

Yine show standby brief komutu ile özet HSRP yapılandırmasını görebilirsiniz.

 

 

PC1’den sunucuya devamlı  ping atalım. Bunun için ping -t 172.16.10.100 komutunu kullanacağız.  Ping işlemi devam ederken R1-R2 arasındaki kabloyu koparın ve durumu izleyin.

Birkaç saniye iletişim kesildi ve sonra devam etti.

 

Reply from 172.16.10.100: bytes=32 time=13ms TTL=126

Reply from 192.168.1.1: Destination host unreachable.

Reply from 192.168.1.1: Destination host unreachable.

Reply from 192.168.1.1: Destination host unreachable.

Reply from 192.168.1.1: Destination host unreachable.

Reply from 192.168.1.1: Destination host unreachable.

Reply from 192.168.1.1: Destination host unreachable.

Reply from 172.16.10.100: bytes=32 time=11ms TTL=126

 

Ctrl+C tuşlarına basarak devamlı ping atma işlemini iptal edebilirsiniz.

 

Son olarak PC1’in ARP tablosunu görüntüleyelim.

 

C:\>arp -a

Internet Address      Physical Address      Type

192.168.1.1           0001.633b.b101        dynamic

192.168.1.2           0004.9a5b.82c2        dynamic

192.168.1.3           0000.0c07.ac0a        dynamic

 

Yukarıdaki çıktıda son satırda sanal IP adresini ve sanal MAC adresini görüyoruz. Sanal MAC adrese dikkat ederseniz. HSRPv1 sanal MAC adresi olan  0000.0c07.acXX yapısında olduğunu görüyoruz. Sondaki 0a grup numarasına eşittir. Burada grup numarası olarak 10 kullanmıştık. 0a’nın heksadesimal olarak 10’a eşit olduğunu hatırlayın.




İlk yorum yapan olun

Bir yanıt bırakın

E-posta hesabınız yayımlanmayacak.


*