Show Komutu Çıktısını Filtreleme




Bir Cisco yönlendirici veya anahtarda çalışan yapılandırma dosyasını görüntülemek için show running-config komutunu kullanırız. Eğer yapılandırma dosyası çok büyükse varsayılan olarak 24 satırdan sonra duraklatılır ve –More– metni görüntülenir. Yapılandırmanın devamını satır satır görmek için Enter tuşuna, sayfa sayfa görmek için boşluk tuşuna basarız. Cisco IOS 15. sürümünden sonra ağ yöneticilerinin işini kolaylaştırmak için show komutu çıktısını filtrelemek ve sadece istedikleri kısımları görüntülemek için | pipe (boru) özelliği getirdi. Klavyeden AltGr+>< tuşuna beraber basarsanız | işaretini çıkarabilirsiniz. show komutundan sonra | işareti ve ek seçeneklerle filtreleme yapılabilir. Filtreleme seçeneklerinden birincisi ve benim çok kullandığım “section” filtresidir. Bu filtre ile seçtiğimiz ifade ile başlayan tüm satırlar gösterilir. Aşağıdaki örnekte bir yönlendiricideki EIGRP yapılandırılması filtrelenerek gösterilmiştir.

R1#show running-config | section eigrp
router eigrp 10
network 192.168.1.0
passive-interface FastEthernet0/0





Yine aşağıdaki örnekte bir yönlendiricideki DHCP yapılandırılması filtrelenerek gösterilmiştir.

R1#show running-config | section dhcp
ip dhcp pool CCNA
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8
domain-name CCNA.com
default-router 192.168.1.1
lease 7

Diğer bir filtreleme seçeneği “include” filtresidir. Bu filtre ile filtreleme ifadesi ile eşleşen tüm çıktı satırları gösterir. Aşağıdaki örnekte bir yönlendiricideki eigrp geçen satırlar gösterilmiştir.

R1#show running-config | include eigrp
router eigrp 10

Diğer bir filtreleme seçeneği “begin” filtresidir. Bu filtre ile filtreleme ifadesi ile eşleşen satırdan başlamak üzere, belirli bir noktadan sonraki tüm satırları gösterir. Aşağıdaki örnekte bir yönlendiricideki eigrp ile başlayan ve devam eden satırlar gösterilmiştir.
R1#show running-config | begin eigrp
router eigrp 10
network 192.168.1.0
passive-interface FastEthernet0/0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!





Diğer bir filtreleme seçeneği “exclude” filtresidir. Bu filtre ile filtreleme ifadesi ile eşleşen tüm çıktı satırlarını hariç bırakır ve diğer yapılandırma komutlarını gösterir. Aşağıdaki örnekte bir yönlendiricideki eigrp içeren satırlar çıkarılarak diğer satırlar gösterilmiştir.

R1#show running-config | exclude eigrp
Building configuration…

Current configuration : 1725 bytes
!
! Last configuration change at 01:41:36 UTC Wed Feb 15 2017
upgrade fpd auto
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1

 

CCNA R&S sınavına hazırlanıyorsanız veya ağ teknolojileri alanında çalışıyorsanız umarım bu yazıyı faydalı bulmuşsunuzdur. CCNA R&S sınavına hazırlık için hazırladığım aşağıdaki kaynaklara göz atmak isteyebilirsiniz.

CCNA R&S Görsel Eğitim Seti

Ağ Yöneticiliğinin Temelleri Kitabı (CCNA R&S v3 ile birebir uyumludur)

Udemy GNS3 ile CCNA Lab Videoları Eğitimi




İlk yorum yapan olun

Bir yanıt bırakın

E-posta hesabınız yayımlanmayacak.


*